Support

Browser support

To ensure the best possible experience with Surveypal we recommend to use the latest versions of Google Chrome, Firefox or Internet Explorer browsers. Surveypal-tool works with older versions of the browsers but there may appear some issues. Issues with Internet Explorer 8 will not be fixed anymore.

If you are not allowed to update your browser, contact your local IT-support for help.

Here are some guidelines of how to check that your browser is up to date:

Google Chrome

Firefox

Internet Explorer

Related topics